CLA Connect Open Forum

Wascomat Emerald SU620 10E Error

  • 1.  Wascomat Emerald SU620 10E Error

    Posted 05-16-2018 23:46
    We have a Wascomat emerald su620 that will pause through its cycle
    at various and random point and issue a "10E" Error - "the drain cycle is too long".
    My crack tech repair guy has given this machine a complete and thorough once over, cleaning out all drains and
    all valves and lines, and the sympton continued. He determined, after hours of testing and pondering, that the the
    PCB / control card must be bad. I sent the card out for "repairs". $250 and 2 weeks later, our states very reputable electronics inverter and card repair outfit has returned the
    PCB. I've just hooked it up and am observing the exact same behavior - hot/warm/col or quick cycle - it will run for perhaps
    15 to 20 minutes into the cycles before the 10E appears. Multiple "start" pushes will get it to the finish line, but it
    will never run cleanly, always needing 3 or 4 start pushes to get to the end.

    I'm going to call the elec. repair biz to find out exactly
    what they observed that was "wrong" with the card, and what components they replaced - maybe this will give me clues as
    to how to proceed - but I doubt it; I don't think the root cause was ever with the card in the first place.

    Repeated calls to Wascomat tech line have had me clean out all pressure lines and hoses, all the regular stuff that my
    pro tech has already done, and to no avail.

    We must be missing something and am hoping that the collective brain out there has had one of your Wascomat SU640/30/20
    Emeralds behave this way and you fought your way to the solution....and you would be kind enough to share the secret with us.

    This SU620E sits in a row of 4 like machines and shares he drain. They function fine, and this group has performed well for years.

    Any ideas would be greatly appreciated and welcome.

    Thanks and Best Wishes to all of our Laundromat Sisters and Brothers in Arms out there,

    Gina and Kurt Van Hook
    Willow Creek Laundromat
    Carrboro, NC
    thumbnail image


    ------------------------------
    Kurt VanHook
    Store Owner/ Employee
    Carrboro NC
    ------------------------------


  • 2.  RE: Wascomat Emerald SU620 10E Error

    Posted 05-17-2018 00:01
    Edited by Richard Heighington 05-17-2018 00:01
    I would start swapping out parts with the machine next to it. The one time I had a random error on a Wascomat it turned out to be a loose cable so I would be swapping out the cables too if possible.
    ------------------------------
    Richard H
    Store owner
    B.C. Canada
    ------------------------------



  • 3.  RE: Wascomat Emerald SU620 10E Error

    Posted 05-17-2018 15:25
    10E is a drain issue.  Water is not draining fast enough.  There has to be a clog in your drain somewhere.  Also, make sure the 2 tension springs are on the washer drain, one on each side of the drain,  and the washer drain is cleaned out

    ------------------------------
    glen

    greensboro NC
    ------------------------------



  • 4.  RE: Wascomat Emerald SU620 10E Error

    Posted 05-17-2018 17:08
    I have 32 of these SU series washers and run into various errors like this.  Whenever my repair guy tries to diagnose it, it usually turns out I need a new inverter.  I have spent so much time and $$$$ fixing these SU washers, and the LED displays have all faded out to the point the customers have to ask what the prices are because they can't read them. My son told me we were making a mistake on these hi-tech washers and he was right.  I have the W series at another laundry and they are bullet-proof 15 years later. If anyone has diagnosed a 10E error, I'd like to know what the actual fix turned out to be.

    ------------------------------
    James Radovic
    Owner
    Jupiter Laundry and Downtown Stuart Laundry
    Jupiter and Stuart, FL
    CLA Member since 2000
    ------------------------------



  • 5.  RE: Wascomat Emerald SU620 10E Error

    Posted 05-19-2018 15:06
    I had this issue on an emerald 640.  It drove me crazy for years.  It was the fourth machine in the row of four, and eventually all four started doing it.  It was the main drain that these four machines are tied into.  The four inch main drain was FILLED with coins!  It cost $450 to clean two drains and I got $250 out of the drain.  There is probably that much more in the lint trap that I will retrieve at a later date.  All machines have run fine since.

    Bob

    ------------------------------
    Bob
    Saint Peters MO
    ------------------------------



  • 6.  RE: Wascomat Emerald SU620 10E Error

    Posted 05-21-2018 10:24
    Hey Bob.  Great answer.  I had a similar issue a few years back.  The main pipe J-trap drain was filled with coins.  Cost $185 for the plumber to figure out the problem but I retrieved $250 worth of coins.  Most of the pennies were rotted through but the rest was good.

    ------------------------------
    James Radovic
    Owner
    Jupiter Laundry and Downtown Stuart Laundry
    Jupiter and Stuart, FL
    CLA Member since 2000
    ------------------------------