Open Forum

Speed Queen Extractor Not Spinning completely on Final Spin

  • 1.  Speed Queen Extractor Not Spinning completely on Final Spin

    Posted 9 days ago
    Good Sunday Everyone,
    I have a Speed Queen SC35MD2 Hardmount Extractor. At final spin, it will spin up to speed for a couple of seconds, slow down, then spin back up to speed for a couple of seconds and this repeats 4 times. At the end of the 4th time, it stops completely as if it completed cycle. All the clothes remain wet as the spin cycle does not consistently stay on. The water drains normally and I checked the valve and drain hoses-they are clear.

    If I manually advance to the spin cycle, it will stay on and perform the spin cycle as it normally should. I dont understand???

    Hoping you experienced folks can point me in the right direction. Thanks you!

    ------------------------------
    eric wagner
    Store Owner/ Employee
    gresham OR
    ------------------------------


  • 2.  RE: Speed Queen Extractor Not Spinning completely on Final Spin

    Posted 9 days ago
    Eric,

    That sounds like a classic issue of blocked drain or blocked dump valve.
    The motor is straining and cycling on & off because of soap suds that will not drain.
    Soap suds that don't drain will put a heavy load on the spin of a basket, thereby staring the motor to cycle on & off.
    It's sort of like trying to run in a swimming pool of 5 foot water.

    ------------------------------
    Paulie B
    Multiple Mat Owner since 1976
    New York City, NY
    ------------------------------



  • 3.  RE: Speed Queen Extractor Not Spinning completely on Final Spin

    Posted 9 days ago
    I checked/removed the drain hose at the bottom of the tub that leads to the drain valve, checked the hose from drain valve to the main drain line and  hacked the valve itself with hoses removed and I didn't see any obstruction.

    Just curious why the water drains normally after the rinse cycle, then goes to spin cycle and has the issue, but when I manually advance to spin cycle there's no issue?

    During the normal transition from rinse to spin, the water drains normally and there is no excess pooling in the bottom of the tub, as far as I can tell.

    Thanks , Paulie for the info.  I am still pretty new to this. Where is the dump valve located?

    Thanks 











    ------------------------------
    eric wagner
    Store Owner/ Employee
    gresham OR
    ------------------------------



  • 4.  RE: Speed Queen Extractor Not Spinning completely on Final Spin

    Posted 9 days ago
    Check where your washer drain hose connects to the main drain pipe.
    Oftentimes obstructions get hung up at that connection behind the washer.
    Dump valve = drain valve.

    ------------------------------
    Paulie B
    Multiple Mat Owner since 1976
    New York City, NY
    ------------------------------



  • 5.  RE: Speed Queen Extractor Not Spinning completely on Final Spin

    Posted 9 days ago
    I'll pull it back off and check again. I'll keep you posted.

    ------------------------------
    eric wagner
    Store Owner/ Employee
    gresham OR
    ------------------------------



  • 6.  RE: Speed Queen Extractor Not Spinning completely on Final Spin

    Posted 8 days ago
    Problem solved! Yes Paulie, you were correct. I pulled the downstream hose off the drain valve and went further down to the p-trap-which I didnt check originally. I only checked the straight hose.
    The p-trap was full of debris. A pen was caught in the trap, blocking debris and causing the problem. Ran 4  full cycles with no recurring issue.


    I love this forum!

    ------------------------------
    Brian Alabe
    Store Owner/ Employee
    Maytag Laundromat
    Seattle WA
    ------------------------------



  • 7.  RE: Speed Queen Extractor Not Spinning completely on Final Spin

    Posted 8 days ago
    That's great! So glad to help.

    Brian....or are you Eric?

    ------------------------------
    Paulie B
    Multiple Mat Owner since 1976
    New York City, NY
    ------------------------------



  • 8.  RE: Speed Queen Extractor Not Spinning completely on Final Spin

    Posted 7 days ago
    Is thus a front loader?

    ------------------------------
    Edward Davis
    Potential Investor
    Lees Summit MO
    ------------------------------



  • 9.  RE: Speed Queen Extractor Not Spinning completely on Final Spin

    Posted 7 days ago
    You are so right Paulie,
    I just went through this on a SQ 30lb.  The dreaded EUB error had me swapping drain value and circuit boards around.  I spent most of a day on it.  Finally I noticed it was one of two machines that had an extra 2' of drain with 2-90 degree elbows to make it to the trough.
    Yep, bra wire caused a bunch of other crud to collect.  Drained slow enough to keep load wet enough to cause unbalance error.


    ------------------------------
    Bruce Keckhafer
    Store Owner/ Employee
    Laundry Max
    Mankato MN
    ------------------------------